Welcome! Log In Create A New Profile

Advanced

XL Pro....... no GB “ground beep”

March 16, 2020 04:49PM
My XL Pro has decided not to emit the “Ground” beep when doing the GB procedure. I get the first beep when in the “Air” position but not in the “Ground” position. The detector sounds perfectly balanced and operates just fine. Same problem with all three coils. I have emailed Whites but no response just yet. Is the second beep just a confirmation that the GB procedure is complete because the GB sounds like it has done the job okay with little or no tone variation when raising or lowering the coil. Lowering the Signal Balance doesn’t help. As mentioned, every other aspect of the detector’s operation is perfect.
Thanks for any ideas
Tony

White’s XL Pro
White’s MX7
White’s TDI BeachHunter
Subject Author Views Posted

XL Pro....... no GB “ground beep”

Tony 246 March 16, 2020 04:49PM

It happened to me, if I recall, twice.

Monte 162 March 17, 2020 01:43AM

Re: It happened to me, if I recall, twice.

Tony 125 March 17, 2020 04:54AM

The XL Pro is working well for you.thumbs up

Monte 144 March 17, 2020 05:19AM

Re: The XL Pro is working well for you.thumbs up

Tony 143 March 18, 2020 02:33AM

XL Pro .. Locked GB .. High Sig. Bal. but stable .. 8" Royal 800 = Great set-up.thumbs up N/T

Monte 135 March 18, 2020 04:31AM

Re: XL Pro....... no GB “ground beep”

flintstone 168 March 16, 2020 06:06PM

Re: XL Pro....... no GB “ground beep”

Tony 152 March 16, 2020 07:15PM



Sorry, only registered users may post in this forum.

Click here to login

Online Users

Guests: 31
Record Number of Guests: 356 on August 30, 2020